I am trying to use the Alternet libraries in my own application, but it seems to be failing the license check. When I try to instantiate a TextEditor, an exception is thrown with: "No License Information found."
I ran LicenseActivation.exe with my license key and it was successful. I even used the -deactivate keyword to clear the activation and try again, but I still get this error.
If I comment out license enforcement from the source code and run from locally-built binaries, it works, but obviously I don't want to go down that route.
Hi Walter,
Please make sure you have a licx file added to your project with the following contens : Alternet.Editor.SyntaxEdit, Alternet.Editor, Version=, Culture=neutral, PublicKeyToken=8032721e70924a63
This file should be created automatically by Visual Stuido if you drag SyntaxEdit to your form from Visual Studio toolbox, however if you're creating SyntaxEdit from code, you need to make sure you have such file in the project. If it does not help, could you please check if compiling and running one of our demos exhibits the same issue? In this case, could I ask you to send me a content of the following folder: C:\ProgramData\Alternetsoft\Licenses, so I can try reproducing the problem on my tests?
Manually creating licenses.licx and adding it to my project resolved this issue. Thanks!
Hi, I'm having the same trouble with the WPF Editor that I recently purchased. It does not appear in the toolbox so I create it manually via XAML. Need to embed the license info in the licx file, can you let me know the proper line to enter?
You should add this line to the Licenses.licx file:
Alternet.Editor.Wpf.TextEditor, Alternet.Editor.Wpf.v5, Version=, Culture=neutral, PublicKeyToken=8032721e70924a63